▀ Ethernet Virtual Circuit using Trunk EFP
▄ Cisco ASR 903 Router Design and Deployment Guide
interface BDI10 ! subnet A
ip address 172.16.10.1 255.255.255.0
!
interface BDI11
ip address 172.16.11.1 255.255.255.0 ! subnet B
ASR903-PE1 Configuration
interface GigabitEthernet0/1/0
no ip address
negotiation auto
service instance 10 ethernet
encapsulation dot1q 10
bridge-domain 30 ! bridge-domain will be S-Tag on trunk port
!
service instance 11 ethernet
encapsulation dot1q 11
bridge-domain 40 ! bridge-domain will be S-Tag on trunk port
interface GigabitEthernet0/1/2
no ip address
negotiation auto
service instance trunk 1 ethernet
encapsulation dot1q 30-40 ! in this case, we only need vlan 30 and 40
rewrite ingress tag pop 1 symmetric
bridge-domain from-encapsulation ! outer vlan tag will be used as bridge-
domain
ASR903-PE2 Configuration
interface GigabitEthernet0/1/0
no ip address
negotiation auto
service instance 10 ethernet
encapsulation dot1q 10
bridge-domain 30 ! bridge-domain will be S-Tag on trunk port
!
service instance 11 ethernet
encapsulation dot1q 11
bridge-domain 40 ! bridge-domain will be S-Tag on trunk port
interface GigabitEthernet0/1/2
no ip address
negotiation auto
service instance trunk 1 ethernet
encapsulation dot1q 30-40 ! in this case, we only need vlan 30 and 40
rewrite ingress tag pop 1 symmetric
bridge-domain from-encapsulation ! outer vlan tag is used as bridge-domain
ASR903-CE2 Configuration
interface GigabitEthernet0/1/2