Configuring ISG Access for IP Subscriber Sessions
Configuration Examples for ISG Access for IP Subscriber Sessions
36
DHCP-Initiated Session Recovery: Example
The following example configures an ISG policy that applies a service called “FIRST-SERVICE” upon
session restart for subscribers belonging to the VRF “FIRST”.
class-map type control TEST
match vrf FIRST
policy-map type control GLOBAL
class type control TEST event session-restart
1 service-policy type service name FIRST-SERVICE
ISG Interface with DHCP Class-Aware Capability: Example
In the following example, GigabitEthernet interface 1/0/0.400 is configured with DHCP class-aware
functionality, which enables ISG to influence DHCP IP address assignment. If the service
“SERVICE_DHCP” is activated, the DHCP pool “DHCP_POOL2” is used for address assignment.
Otherwise, the default pool “DHCP_POOL1” is used.
interface GigabitEthernet1/0/0.400
encapsulation dot1Q 400
ip address 10.1.15.1 255.255.255.0 secondary
ip address 10.1.10.1 255.255.255.0
no snmp trap link-status
service-policy type control RULE_406a
ip subscriber l2-connected
initiator dhcp class-aware
!
ip dhcp excluded-address 10.1.10.1
!
ip dhcp pool DHCP_POOL1
network 10.1.10.0 255.255.255.0
default-router 10.1.10.1
lease 0 0 30
class default
!
ip dhcp class default
!
ip dhcp pool DHCP_POOL2
network 10.1.15.0 255.255.255.0
default-router 10.1.15.1
lease 0 0 30
class DHCP_CLASS2
!
ip dhcp class DHCP_CLASS2
!
policy-map type service SERVICE_DHCP
classname DHCP_CLASS2
!
DHCP Address Pool Classes and Relay Actions for ISG: Examples
This section contains examples of DHCP address pool configuration and relay actions for ISG.