Configuring a Basic EIGRP Configuration: Example
The following example shows how to configure EIGRP with a policy that filters incoming routes. This is a
typical configuration for a router that has just one neighbor, but advertises other connected subnets.
router eigrp 144
address-family ipv4
metric maximum-hops 20
router-id 10.10.9.4
route-policy GLOBAL_FILTER_POLICY in
log-neighbor-changes
log-neighbor-warnings
interface Loopback0
!
interface GigabitEthernet 0/2/0/0
passive-interface
!
interface GigabitEthernet 0/6/0/0
hello-interval 8
hold-time 30
summary-address 10.0.0.0 255.255.0.0
!
Configuring an EIGRP Stub Operation: Example
The following example shows how to configure an EIGRP stub. Stub operation allows only connected, static,
and summary routes to be advertised to neighbors.
router eigrp 200
address-family ipv4
stub connected static summary
router-id 172.16.82.22
log-neighbor-changes
log-neighbor-warnings
redistribute connected route-policy CONN_POLICY
interface GigabitEthernet0/6/0/0
passive-interface
neighbor 10.0.0.31
!
interface GigabitEthernet0/6/0/1
passive-interface
neighbor 10.0.1.21
!
!
!
Configuring an EIGRP PE-CE Configuration with Prefix-Limits: Example
The following example shows how to configure EIGRP to operate as a PE-CE protocol on a PE router. The
configuration is under VRF CUSTOMER_1. A maximum prefix is typically configured to ensure that one
set of customer routes do not overwhelm the EIGRP process.
router eigrp 500
vrf CUSTOMER_1
address-family ipv4
timers nsf route-hold 300
router-id 172.16.6.11
maximum-prefix 450 70
default-metric 200000 10000 195 10 1500
Cisco ASR 9000 Series Aggregation Services Router Routing Configuration Guide, Release 5.3.x
337
Implementing EIGRP
Configuring a Basic EIGRP Configuration: Example