UMN:CLI User Manual
V5808
590
11.4 Routing Information Protocol (RIP)
Routing Information Protocol (RIP), as it is more commonly used than any other Routing
Protocols, for use in small, homogeneous networks. It is a classical distance-vector
routing protocol with using hop count. RIP is formally defined in documents in Request
For Comments (RFC) 1058 and Internet Standard (STD) 56. As IP-based networks
became both more numerous and greater in size, it became apparent to the Internet
Engineeing Task Force (IETF) that RIP needed to be updated. Consequently, the IETF
released RFC 1388, RFC 1723 and RFC 2453, which described RIP v2 (the second
version of RIP).
RIP v2 uses broadcast User Datagram Protocol (UDP) data packets to exchange routing
information. The V5808 sends routing information and updates it every 30 seconds. This
process is termed advertised. If a router does not receive an update from another router
for 180 seconds or more, it marks the routes served by the non-updating router as being
unusable. If there is still no update after 120 seconds, the router removes all routing table
entries for the non-updating router.
The metric that RIP uses to rate the value of different routes is hop count. The hop count
is the number of routers that should be traversed through the network to reach the
destination. A directly connected network has a metric of zero; an unreachable network
has a metric of 16. This short range of metrics makes RIP an unsuitable routing protocol
for large networks.
A router that is running RIP can receive a default network via an update from another
router that is running RIP, or the router can source (generate) the default network itself
with RIP. In both cases, the default network is advertised through RIP to other RIP
neighbors. RIP sends updates to the interfaces in the specified networks.
If an interface's network is not specified, it will not be advertised in any RIP update. The
V5808 supports RIP version 1 and 2.
11.4.1 Enabling RIP
To use RIP protocol, you should enable RIP.
Step 1 To open Router Configuration mode, use the following command on Global Configuration
mode.
Opens Router Configuration mode and operates RIP
routing protocol.
Restores all configurations involved in RIP to the
default.